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Introductory Notes 

 
This Autodesk® Revit® Getting Started Guide was written using the 2015 version of this product and uses screen 
captures from the full Revit application that includes all disciplines (Architecture, Structure, and MEP).  Please 
note that this tutorial may also be used with dedicated versions of Autodesk® Revit® Architecture or earlier 
versions of Revit going back to release 2012.   
 
Nomenclature used in this tutorial: 

Text entry required by user  Bold 
Command, key entry, or button clicks ALL CAPS 
Selection of named items or elements Italics 
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Getting Started 
 

Understanding the Basics 
 
In this lesson, you learn what Autodesk Revit is and how its parametric change engine benefits you and your 
work. You begin with the fundamental concepts on which Revit is built. You learn the terminology, the hierarchy of 
elements, and how to perform some common tasks in the product. 
 

 Understanding the Concepts 
 

 What is Autodesk® Revit® 2015? 
 

The Revit platform for building information modeling is a design and documentation system that 
supports the design, drawings, and schedules required for a building project. Building information 
modeling (BIM) delivers information about project design, scope, quantities, and phases when you 
need it.  
 
In the Revit model, every drawing sheet, 2D and 3D view, and schedule is a presentation of 
information from the same underlying building model database. As you work in drawing and schedule 
views, Revit collects information about the building project and coordinates this information across all 
other representations of the project. The Revit parametric change engine automatically coordinates 
changes made anywhere—in model views, drawing sheets, schedules, sections, and plans.  

 
What is meant by parametric? 
 
The term parametric refers to the relationships among all elements of the model that enable the 
coordination and change management that Revit provides. These relationships are created either 
automatically by the software or by you as you work. In mathematics and mechanical CAD, the 
numbers or characteristics that define these kinds of relationships are called parameters; hence, the 
operation of the software is parametric. This capability delivers the fundamental coordination and 
productivity benefits of Revit: Change anything at any time anywhere in the project, and Revit 
coordinates that change through the entire project.  
 
The following are examples of these element relationships:  

 
 The outside of a door frame is a fixed dimension on the hinge side from a perpendicular 

partition. If you move the partition, the door retains this relationship to the partition. 

 Windows or pilasters are spaced equally across a given elevation. If the length of the 
elevation is changed, the relationship of equal spacing is maintained. In this case, the 
parameter is not a number but a proportional characteristic. 

 The edge of a floor or roof is related to the exterior wall such that when the exterior wall is 
moved, the floor or roof remains connected. In this case, the parameter is one of association 
or connection. 
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How does Autodesk® Revit® 2015 keep things updated? 
 
A fundamental characteristic of a building information modeling application is the ability to coordinate 
changes and maintain consistency at all times. You do not have to intervene to update drawings or 
links. When you change something, Revit immediately determines what is affected by the change and 
reflects that change to any affected elements.  

 
Revit uses 2 key concepts that make it especially powerful and easy to use. The first is the capturing 
of relationships while the designer works. The second is its approach to propagating building 
changes. The result of these concepts is software that works like you do, without requiring entry of 
data that is unimportant to your design.  
 
Element behavior in a parametric modeler 
 
In projects, Revit uses 3 types of elements:  
 

 Model elements represent the actual 3D geometry of the building. They display in relevant 
views of the model. For example, walls, windows, doors, and roofs are model elements. 

 Datum elements help to define project context. For example, grids, levels, and reference 
planes are datum elements.  

 View-specific elements display only in the views in which they are placed. They help to 
describe or document the model. For example, dimensions, tags, and 2D detail components 
are view specific elements.  
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There are 2 types of model elements: 
 

 Hosts (or host elements) are generally built in place at the construction site. For example, 
walls and roofs are hosts. 

 Model components are all the other types of elements in the building model. For example, 
windows, doors, and cabinets are model components. 
 

There are 2 types of view-specific elements: 
 

 Annotation elements are 2D components that document the model and maintain scale on 
paper. For example, dimensions, tags, and keynotes are annotation elements. 

 Details are 2D items that provide details about the building model in a particular view. 
Examples include detail lines, filled regions, and 2D detail components. 
 

This implementation provides flexibility for designers. Revit elements are designed to be 
created and modified by you directly; programming is not required. If you can draw, you can define 
new parametric elements in Revit. 

 
In Revit, the elements determine their behavior largely from their context in the building. The context 
is determined by how you draw the component and the constraint relationships that are established 
with other components. Often, you do nothing to establish these relationships; they are implied by 
what you do and how you draw. In other cases, you can explicitly control them, by locking a 
dimension or aligning 2 walls, for example.  
 
Understanding Autodesk® Revit® 2015 terms  
 
Most of the terms used to identify objects in Revit are common, industry-standard terms familiar to 
most architects. However, some terms are unique to Revit. Understanding the following terms is 
crucial to understanding the software.  
 
Project: In Revit, the project is the single database of information for your design—the building 
information model. The project file contains all information for the building design, from geometry to 
construction data. This information includes components used to design the model, views of the 
project, and drawings of the design. By using a single project file, Revit makes it easy for you to alter 
the design and have changes reflected in all associated areas (plan views, elevation views, section 
views, schedules, and so forth). Having only one file to track also makes it easier to manage the 
project.  
 
Level: Levels are infinite horizontal planes that act as a reference for level-hosted elements, such as 
roofs, floors, and ceilings. Most often, you use levels to define a vertical height or story within a 
building. You create a level for each known story or other needed reference of the building; for 
example, first floor, top of wall, or bottom of foundation. To place levels, you must be in a section or 
elevation view. 
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Level 2 work plane cutting through the 3D view with the corresponding floor plan next to it 
 
 

Element: When creating a project, you add Revit parametric building elements to the design.  Revit 
classifies elements by categories, families, and types. 

 
Category: A category is a group of elements that you use to model or document a building design. 
For example, categories of model elements include walls and beams. Categories of annotation 
elements include tags and text notes. 

 
Family: Families are classes of elements in a category. A family groups elements with a common set 
of parameters (properties), identical use, and similar graphical representation. Different elements in a 
family may have different values for some or all properties, but the set of properties—their names and 
meaning -- is the same. For example, 6-panel colonial doors could be considered one family, 
although the doors that compose the family come in different sizes and materials. 
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There are 3 kinds of families: 
 

 Loadable families can be loaded into a project and created from family templates. You can 
determine the set of properties and the graphical representation of the family. 

 
 System families include walls, dimensions, ceilings, roofs, floors, and levels. They are not 

available for loading or creating as separate files. 
 
 Revit predefines the set of properties and the graphical representation of 

system families. 
 

 You can use the predefined types to generate new types that belong to this family within 
the project. For example, the behavior of a wall is predefined in the system. However, 
you can create different types of walls with different compositions. 
 

 System families can be transferred between projects. 
 

 In-place families are custom families that you create in the context of a project. Create an in-place 
family when your project needs unique geometry that you do not expect to reuse or 
geometry that must maintain one of more relationships to other project geometry. 
 
 Because in-place families are intended for limited use in a project, each in-place family 

contains only a single type. You can create multiple in-place families in your projects, 
and you can place copies of the same in-place family element in your projects. Unlike 
system and standard component families, you cannot duplicate in-place family types to 
create multiple types. 
 

Type: Each family can have several types. A type can be a specific size of a family, such as a 30‖ X 
42‖ title block or a 32" x 84" door. A type can also be a style, such as default aligned or default 
angular style for dimensions. 
 
Instance: Instances are the actual items (individual elements) that are placed in the project and have 
specific locations in the building (model instances) or on a drawing sheet (annotation instances). 

 
 

Understanding the Revit User Interface 
 
Revit is a powerful CAD product for the Microsoft® Windows operating system. Its 
interface resembles those of other products for Windows featuring a ribbon that contains the tools 
used to complete tasks. 
 
In the Revit interface, many of the components (such as walls, beams, and columns) are 
available at the click of a button. You can place these components in the drawing and immediately 
determine whether they meet your design requirements. 
 
The Revit interface is designed to simplify your workflow. With a few clicks, you can change the 
interface to better support the way that you work. For example, you can set the ribbon to one 
of the three display settings for optimum use of the interface. You can also display several project 
views at one time, or layer the views to see only the one on top. 
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1 Application Menu 
2 Quick Access Toolbar 
3 InfoCenter 
4 Options Bar 
5 Type Selector 
6 Properties Palette 
7 Project Browser 
8 Status Bar 
9 View Control Bar 

10 Drawing Area 
11 Ribbon 
12 Tabs on the ribbon 
13 A contextual tab on the ribbon, 

providing tools relevant to the 
selected object or current action 

14 Tools on the current tab of the 
ribbon 

15 Panels on the ribbon 
 
Hints 
Project Browser: Select Views label at top of Project Browser window and right click to access 

Properties to change View Filters. 
 
Options Bar:  The features shown in this area are tool dependent. See the Wall Tool example 

below. 
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Architecture Ribbon 
 

 
 

 
 

Structure Ribbon 
 

 
 

 
 

Systems Ribbon 
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Insert Ribbon 
 

 
 

 
 

Annotate Ribbon 
 

 
 

 
 

Analyze Ribbon 
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Massing & Site Ribbon 
 

 
 

 
 

Collaborate Ribbon 
 

 
 

 
 

View Ribbon 
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Manage Ribbon 
 

 
 

 
 

Add-ins Ribbon 
 

 
 
Mark 1:  These are examples of free plug-ins that you may obtain from the Autodesk Exchange to 
   add additional productivity enhancements to Revit. 
 
The Autodesk Exchange app link is located in the upper right hand corner of the user interface next to 
the help button. 

 
 

Modify Ribbon 
 

 
Context tabs display as you work. The Modify | Place Wall context tab is shown. 
 
Note: Context tabs only appear when an object of that type is selected in the canvas window. 
 
Walls    Doors   Windows 
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The View Cube 
 
You can click and drag the ViewCube to reorient the view of a model to a custom viewpoint or click on 
one of the twenty-six predefined viewpoints that are available. As you drag, the mouse pointer 
changes to indicate that you are reorienting the current view of the model. If you drag the ViewCube 
close to one of the preset orientations and it is set to snap to the closest view, the ViewCube rotates 
to the closest preset orientation. 
 

 
 

The Steering Wheel 
 
Pressing and dragging on a wedge of a wheel is the primary mode of interaction. After a wheel is 
displayed, click one of the wedges and hold down the button on the pointing device to activate the 
navigation tool. Drag to reorient the current view. Releasing the button returns you to the wheel. 
 

 
 

Navigation Bar 
 
You can control which navigation tools are displayed on the navigation bar with the Customize menu. 
The Customize menu is displayed by clicking the Customize button. From the Customize menu, you 
click the navigation tools that you want displayed on the navigation bar. The position of the navigation 
tools on the navigation bar is predefined and cannot be changed. 
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Creating a Project 
 

In this first exercise, you create and name a project in which you will create the building model shown. 
 

 
 
The completed project.  (Ambient shadows and gradient background not included in this tutorial) 
 

 

01   Create a project 
 

1) Launch the Autodesk® Revit®   application. 

2) Click  ► New ► PROJECT. 

3) In the New Project dialog box, under Create New, verify that Project is selected. 

4) Under Template file, verify the second option is selected, and click BROWSE. 

5) Verify C:\ProgramData\Autodesk\RVT 2015\Templates\US Imperial \default.rte 

[DefaultMetric.rte] is selected, and click OPEN. 

6) In the New Project dialog box, click OK. 

 

02   Name and save the project file 

 

1) Click  ► SAVE. 

2) In the left pane of the Save As dialog box, click DESKTOP, and then, in the upper right 
corner of the dialog box, click the CREATE A NEW FOLDER ICON, give the folder the 
name of Training Files. 

   
3) Make Training files the active folder. 

 
4) For File name, enter Revit 2015_Getting Started, and click SAVE. 
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03   Zoom to a view 

 
1) In Project Browser, double-click Elevations (Building Elevation) ► SOUTH. 

 
2) Enter ZR, to zoom to a specific region. Note that the cursor changes to a magnifying 

glass. 
 

3) In the drawing area, move the cursor diagonally and click to draw a rectangle around the 
level markers. The area within the rectangle is magnified to fill the drawing area so that 
you can work with the level marker text. 

 

 

04   Rename levels 

 
1) Double-click the Level 1 text, enter 00 Foundation, and press ENTER. Use a number as 

a prefix to the name so the plans are sorted by level. 
 
2) In the Alert dialog box, click YES to rename corresponding views. The floor and ceiling 

plans for Level 1 are renamed 00 Foundation. 
 

 
 

3) Using the same method, rename Level 2 and its corresponding views as  
01 Lower Level. 
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05   Create levels in the building 

 
1) Enter ZO to zoom out. 

2) Click Architecture tab ► Datum panel ►  LEVEL. 

3) On the Draw panel, click   PICK LINES. 

4) On the Options Bar enter 10 [3000 mm] for the Offset. 

5) In the drawing area, highlight the 01 Lower Level line; when a dashed line is displayed 
above the level line, click to create a level (Level 3). 

 
6) Using the same method, create a level above Level 3. 

 
7) On the Panel Level tab, click MODIFY to end the command. 
 
8) Rename the new levels and all corresponding views: 

 
 Level 3: Rename as 02 Entry Level 

 Level 4: Rename as 03 Roof 
 

9) Double-click the level dimensions, and enter new values: 
 
 0' 0'' [0 mm]: Change to -14' 0'' [-5250 mm] 

 10' 0'' [4000 mm]: Change to -10' 0'' [-3050 mm] 

 20' 0'' [7000 mm]: Change to 0' 0'' [0 mm] 

 30' 0'' [10000 mm]: Change to 10' 0'' [3050 mm] 

10) Press ESC twice to deselect and exit command. 
 
11) Save the project file. 

 
 
 
 

Creating Walls 
 

In this exercise, you work on different levels to add foundation walls to the project. 
 

 
 

The completed exercise 
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06   Create walls 

 
1) In Project Browser, under Floor Plans, double-click 00 Foundation to open that view in 

the drawing area. 

2) Click Architecture tab ► Build panel ►  WALL. 
 
3) In Properties palette ► Change Element Type drop-down and select Basic Wall: 

Retaining - 12'' Concrete [Basic Wall : Retaining - 300mm Concrete]. 
 
4) On the Options Bar below the tool ribbon: 

 
 For Height, select 02 Entry Level. 

 For Location Line, verify that Wall Centerline is selected. 

 Verify that Chain is selected. 

5) In the drawing area, draw walls on the foundation level: 
 
 Click in the lower-right quadrant to select the wall start point. 

 Move the cursor to the left, enter 40' [12000 mm], and press ENTER. 

NOTE: You do not need to specify the unit; Autodesk® Revit® software uses the 
units specified in the project template. 
 

 Beginning at the new endpoint, move the cursor up, enter 22' [6900 mm], and press 
ENTER. 
 

 Move the cursor to the right, enter 40' [12000 mm], and press ENTER. 
 

6) On the Modify | Place Wall tab, click MODIFY to exit the command. 

7) In Project Browser, under Floor Plans, double-click 01 Lower Level. 

8) Click Architecture tab ► Build panel ► WALL. 

9) In Properties palette ► Change Element Type drop-down and select Basic Wall: 
Foundation - 12'' Concrete [Basic Wall : Foundation - 300mm Concrete]. 

 
10) On the Options Bar, for Depth, select 00 Foundation and for Location Line, verify that 

Wall Centerline is selected. 
 

11) Draw walls on the lower level: 
 

 In the drawing area, click the right endpoint of the south wall as the wall start point. 

 Move the cursor to the right, enter 6' 6'' [1950 mm], and press ENTER. 

 Move the cursor up, enter 5' [1500 mm], and press ENTER. 

 Move the cursor to the right, enter 10' 6'' [3150 mm], and press ENTER. 

 Move the cursor up, and select the intersection with the extension of the north wall. 
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 Select the right endpoint of the north wall to complete the chain and connect the 
walls. 

 
12) On the Place Wall panel, click MODIFY. 
 
13) Save the project file. 

 
 

Creating Terrain 
 

In this exercise, you create a 3D view and add a toposurface to the building site. 

 
 

 
The completed exercise 

 

07   Creating terrain 

 
1) In Project Browser, under Floor Plans, double-click 02 Entry Level. 
 
2) Create a 3D view: 

 Click the View tab ► Create panel ► 3D View drop-down ►   CAMERA. 

 Click in the upper-right corner of the drawing area to place the camera. 
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 Click to place the camera target point, as shown. 

 
 
A 3D view is created. The view you create may differ slightly from the illustrations shown 
in the exercises because of minor variations in camera placement. Drag the blue circular 
controls that display on the crop region of the resulting view so that you can see the 
building. 
 

3) In Project Browser, expand 3D Views, right-click 3D View 1, and click RENAME. 
 
4) In the Rename View dialog box, enter To Building, and click OK. 

 
5) Create a graded building site: 

 
 In Project Browser, under Floor Plans, double-click Site. 

 Click Massing & Site tab ► Model Site panel ►  TOPOSURFACE. 

 On the Options Bar, for Elevation, enter -0' 6'' [-150 mm]. 

 Add points to the left of the building, as shown. The order of the point selection is not 
important. 

 
 
 

 On the Options Bar, for Elevation, enter -10' [-4000 mm]. 
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 Add points near the center of the building, as shown. Contour lines are displayed. 
 

 
 

 On the Options Bar, for Elevation, enter -11' [-4300 mm]. 

 Add points to the right of the building, as shown. 

  

 Click Edit Surface tab ► Surface panel ►  FINISH SURFACE. 

 
6) Create a pad surface: 

 Click Massing & Site tab ► Model Site panel ►  BUILDING PAD. 

 On the Draw panel, click  RECTANGLE. 

 Select the outer endpoint at the lower left of the building, as shown. 

 Select the outer endpoint at the upper right of the building. 
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 On the Create Pad Boundary tab, in the Building Pad panel, click  FINISH EDIT 
MODE. 

 
7) Open the To Building 3D view to see the results. 
 
8) Save the project file. In this exercise, you created a simple toposurface in Autodesk Revit 

by selecting points. 
 
However, for most projects, complex site models created by civil engineering 
professionals will be provided to you in DWG, DXF, DGN, or point files. You can import 
these files into your Revit project where you can automatically generate a terrain using 
the Toposurface tool. 

 

Adding Exterior Walls 
 

In this exercise, you build upon the foundation walls. You use the Draw option to create exterior walls 
that extend to the roof level. 

 
 

 
The completed exercise 
 
 

 



A u t o d e s k ®  R e v i t ®  G e t t i n g  S t a r t e d  G u i d e  | 23 

08   Adding exterior walls 

 
1) Add walls to the entry level: 

 
 In Project Browser, under Floor Plans, double-click 02 Entry Level. 

 Click Architecture tab ► Build panel ► WALL. 

 In Properties palette ► Change Element Type drop-down and select Basic Wall : 
Generic - 6'' [Basic Wall : Generic - 200mm]. 

 
 On the Options Bar: for Height, select 03 Roof, and for Location Line, select Core 

Face: Interior.  
 

The Height setting defines how tall the wall is and establishes a relationship between 
the walls and the roof. After you draw the walls, if you change the roof height, the 
height of the walls will also change. 

 
 Beginning at the bottom right, trace the interior of the three existing retaining walls by 

selecting endpoints. 
 

 
 

 On the Place Wall tab, click MODIFY. 

 
2) Add walls to the lower level: 

 
 Open the 01 Lower Level floor plan. Notice that the foundation walls are now visible 

at the right of the plan, so that you can trace them. 
 

 Click Architecture tab ► Build panel ► WALL  
 

 In Properties palette ► Change Element Type drop-down and select Basic Wall : 
Generic - 6'' [Basic Wall : Generic - 200mm]. 

 
 On the Options Bar, for Height, select 03 Roof. 

 Beginning at the left endpoint of the north foundation wall, trace the interior of the 
foundation walls by selecting endpoints. 
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 On the Place Wall tab, click MODIFY. 

 
3) Open the To Building 3D view. 
 
4) Save the project file. 

 
 

Adding a Roof 
 

In this exercise, you create a roof using the footprint of the exterior walls. You specify an offset as you 
create the roof so that the roof has an overhang. 

 
 

 
The completed exercise 

 

09   Adding a roof 
 

1) Open the 03 Roof floor plan. 
 
2) Draw a roof line: 

 Click Architecture tab ► Roof drop-down ►  ROOF BY FOOTPRINT. 

 On the Draw panel, click  LINE. 

 In the Options Bar, verify that Defines slope is selected. 

 To draw the first roof segment, begin at the bottom left and trace the exterior edge of 
the South wall by selecting the left wall endpoint and the intersection of the South 
and far-east wall. 
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3) Create offset roof lines: 

 On the Draw panel, verify  PICK WALLS is selected. 

 On the Options Bar, for Offset, enter 3' [900 mm], and clear Defines slope. 

 
 
 

 In the drawing area, highlight the West wall; when a dashed line is displayed on the 
exterior of the wall, click to place the roof line. Repeat for the North and East walls. 

 
4) Use the Trim/Extend tool to close the roof sketch: 

 On the Edit panel, click  TRIM. 

 Select the east roof line, and then select the South roof line. Repeat for the West and 
South roof lines. 

 
 

 On the Create Roof Footprint panel, click   FINISH EDIT MODE. The resulting 
roof has an odd slope, which you correct in the next step. 
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5) Modify the roof slope: 
 
 Select the roof. 

 In the Properties palette, under Dimensions, for Slope, enter 1''/12" [5°], and click 
APPLY. 

 
 Click in the Drawing area to deselect the roof. 

6) Open the To Building 3D view. Select and modify the crop region as necessary to see the 
roof. The walls are not attached to the roof; you will attach them in a later exercise. 

 
7) Save the project file. 

 
 
 

Adding Floors 
 

In this exercise, you create floors in the building model. 
 
To create floors in Autodesk Revit, you must sketch them first in a sketch editor. You use 
two different sketching options, Pick and Draw, to sketch the floors. 
 

 

10   Adding floors 

 
1) Open the 01 Lower Level floor plan. 
 
2) Create a floor using the Pick method: 

 Click Architecture tab ► Build panel ►  FLOOR. 

 On the Draw panel, click  PICK LINES. 

 On the Options Bar, verify that Offset is 0. 

 Beginning with the North wall and moving counterclockwise, select the interior of the 
walls. 
 

 On the Modify | Create Floor Boundary tab, click MODIFY. 
 
3) Enter ZR, and zoom in to the top-right corner of the model. If the floor lines do not create 

a closed sketch, the sketch is invalid and you need to clean the lines up. To be valid, the 
sketch must be a closed loop with no disconnected or crossing lines.
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4) Create a closed sketch: 

 On the Create Floor Boundary tab, click  TRIM. 

 Trim as necessary, selecting the portion of each line you want to retain. 

 
 

 Enter ZP to zoom to the previous display. 

 Click Modify | Create Floor Boundary tab ► Mode panel ► FINISH EDIT MODE. 
 

5) In the Alert dialog box, click NO. 
 

If you clicked Yes, the walls that finish on the lower level would be trimmed to the 
underside of the floor. 
 
Lower level floor highlighted in blue below. (shown for reference only) 

 
 

6) Create a floor using the Draw method: 
 
 Open the 02 Entry Level floor plan. 

 Click Architecture tab ► Build panel ► FLOOR. 

 On the Draw panel, click  LINE. 

 On the Options Bar, verify that Chain is selected. 
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 Beginning at the South end of the West wall, select the interior endpoint of the West 
wall, and then select the upper endpoint. 

 
 

 Move the cursor to the right and enter 36' [10000 mm], and hit ENTER to accept. 
This is known as the direct distance entry method. 
 

 Move the cursor down and enter 16' 6'' [5300 mm] and hit ENTER to align with the 
outside of the wall, and click to specify the point. 

 
 Move the cursor to the right and enter 25' [9000 mm], and hit ENTER. 

 Move the cursor down and enter 4' 6' [1300 mm] and hit ENTER to align with the 
inside of the wall, and click. 
 

 Move the cursor to the left, enter SZ to find the loop endpoint, and select the 
endpoint to complete the floor sketch. 

 
 

 Click Modify | Create Floor Boundary tab ► Mode panel ► FINISH EDIT MODE. 
 

7) In the Alert dialog box, click NO. 
 
8) View the floors in 3D: 

 Open the To Building 3D view. 

 Select the wall as shown. 
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 On the View Control Bar, click Temporary Hide/Isolate ► HIDE ELEMENT. The 
selected wall is temporarily hidden so that you can see the interior floors. 

 

 
 

 On the View Control Bar, click Visual Style ► SHADED. 

 On the View Control Bar, click Temporary Hide/Isolate ► RESET TEMPORARY 
HIDE/ISOLATE. 
 

Entry Level floor highlighted in blue below. (shown for reference only) 
 
 

 
 

9) Save the project file. 
 
 

Adding Interior Walls 
 

In this exercise, you add walls on the lower level and the entry level, and then modify the walls to 
create rooms in the building. 
 

 
 

The completed exercise 
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11   Adding interior walls 

 
1) Open the 01 Lower Level floor plan. 

 
2) Click Architecture tab ► Build panel ► WALL. 
 
3) In Properties palette ► Change Element Type drop-down and select  

Basic Wall : Generic - 6'' [Basic Wall : Generic - 200mm]. 
 
4) On the Options Bar: 

 
 For Height, select 02 Entry Level. 

 For Location Line, select WALL CENTERLINE. 

 Clear Chain. 

 

5) Add walls: 
 
 Zoom in to the West wall, move the cursor along the North wall centerline, enter 26' 

[8000 mm], and press ENTER to specify the wall start point. Move the cursor down, 
and click on the South wall centerline to complete wall 1. 
 

 On the Modify | Place Wall tab, click MODIFY. 

 Right-click on the wall, and click CREATE SIMILAR. 

 Using the following illustration as a guide, place additional walls to create rooms. 

 

6) Modify walls to create a corridor: 

 Click Modify tab ► Edit panel ►  SPLIT. Click on wall 1 in the area highlighted 
below. 

 

 On the Edit panel, click  TRIM. 

 Trim the split wall to create a corridor, as shown. 
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7) On the Modify tab, click MODIFY. 

8) Draw walls: 

 Open the 02 Entry Level floor plan. 

 Right-click on one of the half-tone walls shown in the underlay of the lower level, and 
click CREATE SIMILAR. 

 
 Using the following illustration as a guide, place additional walls to create rooms as 

highlighted in blue below. 
 

 

 

9) On the Modify tab, click MODIFY. The walls defining the rooms on the lower level and the 
entry level are complete. 
 

10) Save the project file. 
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Adding Doors 
 

In this exercise, you load doors from the Revit Library folder into the project, and then add interior and 
exterior doors to the model. 

 
The completed exercise 
 
 

12   Adding doors 

 

1) Click ► Architecture tab ► Build panel ►  DOOR. 

There are a limited number of door types in the project because there were few in the 
default template. You can load additional door types from the Revit Library folder. 

 
2) Load doors from the Training Files folder: 

 On the Model panel, click LOAD FAMILY. 

 In the left pane of the Load Family dialog box, click IMPERIAL LIBRARY [Metric 

Library], and double-click on the DOORS folder. 

 While pressing CTRL, select the door types: Bifold-4 Panel.rfa, Double-Glass 1.rfa, 

Single- Glass 1.rfa [M_Bifold-4 Panel.rfa, M_Double-Glass 1.rfa, M_Single-Glass 

1.rfa]. 

 Click OPEN. 

3) Add exterior doors: 

 Open the 01 Lower Level floor plan. 

 Click Architecture tab ► Build panel ► DOOR. 

 On the Options Bar, clear Tag on Placement. 

 In Properties palette ► Change Element Type drop-down and select Double-Glass 1 
: 72'' x 84'' [M_Double-Glass 1 : 1830 x 2134mm], add a door to the east wall as 
shown, and then click MODIFY. 
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 Open the 02 Entry Level floor plan. 

 Click Architecture tab ► Build panel ► DOOR. 

 In Properties palette ► Change Element Type drop-down and select Double-Glass 1 
: 72'' x 84'' [M_Double-Glass 1 : 1830 x 2134mm]. 

 
 Place the door in the North wall 7' [2100 mm] from the end of the retaining wall, as 

shown. 
 

 In Properties palette ► Change Element Type drop-down and select Single-Glass 1 : 
36'' x 84'' [M_Single-Glass 1 : 0915 x 2134mm]. 

 
 Place the door in the short vertical wall, as shown. 

 
. 

NOTE: To change the swing direction as you place a door, press the SPACEBAR. To 

change the swing after a door is placed, click the flip arrows. 

 
 
 

4) Add interior doors: 
 
 In Properties palette ► Change Element Type drop-down and select Single-Flush : 

32'' x 84'' [M_Single-Flush : 0813 x 2134mm], and add two doors, as shown. 
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5) Open the 01 Lower Level floor plan. 
 
 Click Architecture tab ► Build panel ► DOOR. 

 In Properties palette ► Change Element Type drop-down and select Single-Flush : 
30'' x 84'' [M_Single-Flush : 0762 x 2134mm], and place two doors, as shown. 

 

 
 

 In Properties palette ►  Change Element Type drop-down and select Bifold-4 Panel : 
72'' x 84'' [M_Bifold-4 Panel : 1830 x 2134mm], and place two doors, as shown. 

 

 
 

6) Open the To Building 3D view. 
 
7) For an unobstructed view of the doors, select a wall, and on the View Control Bar, click 

Temporary Hide/Isolate ► HIDE CATEGORY. All the walls in the view are hidden. 
 
8) On the View Control Bar, click Temporary Hide/Isolate ► RESET TEMPORARY 

HIDE/ISOLATE. 
 
9) Save the project file. 
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Adding Windows 
 

In this exercise, you work in elevation and plan views to add windows to the model. You use 
alignment and dimension tools to more precisely position the windows. 

 
The completed exercise 
 

13   Adding windows 

 
1) Add windows in an elevation view: 

 Open the South elevation view, and zoom in to the building. 

 Click Architecture tab ► Build panel ►  WINDOW. 

 On the Options Bar, clear Tag on Placement.  (white background) 

 
 

 On the Model panel, click LOAD FAMILY. 

 In the left pane of the Load Family dialog box, click Imperial Library [Metric Library], 
and double-click on the WINDOWS folder to open it. 

 
 Select Casement 3x3 with Trim.rfa [M_Casement 3x3 with Trim.rfa], and click Open. 

 Add two windows, approximately as shown. You will position them and align them 
with the top of the retaining wall later. If either of the windows spans an internal wall, 
a warning about the conflict is displayed; close the warning. You will resolve any 
conflict by moving the windows while in a floor plan view. 
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2) Open the 01 Lower Level floor plan. Because the windows are at the top of the wall, they 
are above the current view range for the plan. 

 
3) Modify the view range: 

 
 In the Properties palette, under Extents, for View Range, click EDIT. 

 In the View Range dialog box, for Cut plane Offset, enter 7' [2160 mm]. 

 Click OK. The windows are now visible in the South wall. 
 
4) If necessary, move the windows to resolve the conflict with the wall: 

 
 Select the right window, and drag it 2' 6'' [200 mm] to the left side of the interior wall. 

Select the window and edit the temporary dimensions, as needed. 
 

 Select the left window, and drag it 9' 6'' [2775 mm] to the right of the West wall. 
 

 
5) Create a window type: 

 
 Open the South elevation view and select the window on the left. 

 In Properties palette ► click  EDIT TYPE. 

 In the Type Properties dialog box, click DUPLICATE. 

 In the Name dialog box, for Name, enter 36'' x 36'' [0915 x 0915 mm], and click OK. 

 In the Type Properties dialog box, under Dimensions, for Height, enter 3' [915 mm]. 

 Click OK. 

6) Modify a window: 
 
 Select the window on the right. 

 In Properties palette ► Change Element Type drop-down and select Casement 3x3 
with Trim : 36'' x 36'' [M_Casement 3x3 with Trim : 0915 x 0915mm]. 
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7) Align the windows to the top of the retaining wall: 

 Click Modify tab ► Edit panel ►  ALIGN. 

 Select the top of the wall, and then select the top edge of the trim of one of the 
windows. Be careful to select the top of the wall, and not the 02 Entry Level line. 

 
 Repeat for the second window. 

 

 
 

8) Add windows in plan view: 
 
 Open the 02 Entry Level floor plan, and zoom in to the West side of the model. 

 In the Properties palette, under Graphics, for Underlay, select NONE, and click 
APPLY. 

 Click View tab ► Graphics panel ►  THIN LINES so that element lines maintain 
their true thickness in the zoomed view. 
 

 Click Architecture tab ► Build panel ► Window. 

 On the Options Bar, verify that Tag on Placement is cleared. 

 In Properties palette ► Change Element Type drop-down and select Casement 3x3 
with Trim : 36'' x 72'' [M_Casement 3x3 with Trim : 0915 x 1830mm], and place three 
windows on the outside edge of the west wall, as shown. 

 
9) Reposition the windows to be equidistant from each other: 

 

 Click Annotate tab ► Dimension panel ►   ALIGNED. 

 Select the North wall, select each of the window centerlines, and then select the 
horizontal interior wall. 
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 Click to the left of the West wall to place the dimension line. Note that each of the 
four dimensions is different. 

 
 

 Click , and then press ESC twice. The windows are moved so that all of the 
dimensions are equal. 
 

 
 

 Select the interior wall that contains the doors; move it up or down to see how the 
design intent is maintained. 
 

 Select the top wall, move it up 3' [1000 mm], and see how the walls resize and the 
windows redistribute equally within the wall. 
 

 On the Quick Access toolbar, click  UNDO once to restore the top wall to the 
original 
dimension. 
 

10) Select the dimension line, and press DELETE key.  In the Warning dialog box, click OK to 
delete the line but maintain the constraints. 

 
11) Zoom as desired, and open various plan, elevation, and 3D views to display the model 

results thus far. 
 
12) Save the project file. 
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Adding a Curtain Wall 
 

In this exercise, you change existing exterior walls to curtain walls. You then create a curtain wall type 
that you can apply to other walls using the Match Type tool.

 
The completed exercise 
 
 

14   Adding a curtain wall 
 

1) Open the 01 Lower Level floor plan. 

2) Create a curtain wall at the northeast corner of the building: 

 Zoom to the East wall. 

 Click Modify tab ► Edit panel ►  SPLIT, and split the East wall just above the 
door. 

 
 On the Modify tab, click MODIFY. 

 While pressing CTRL, select the upper portion of the East wall and the adjacent 
portion of the North wall. 

 
 In Properties palette ► Change Element Type drop-down and select Curtain Wall : 

Storefront. If a warning displays, click to close it. 
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3) Create a curtain wall type: 
 
 Select the North curtain wall at an end so the whole curtain wall is selected. The 

tooltip and the status bar will confirm the selection. 
 

 In Properties palette, click EDIT TYPE. 

 
 

 In the Type Properties dialog box, click DUPLICATE. 

 In the Name dialog box, for Name, enter House 4' x 4' [House 1200 x 1200 mm], and 
click OK. 
 

 In the Type Properties dialog box, under Vertical Grid Pattern, for Spacing, enter 4' 
[1200 mm]. 
 

 Under Horizontal Grid Pattern, for Spacing, enter 4' [1200 mm]. 

 Click OK twice. 
 
4) Match the type of the north curtain wall to the east curtain wall: 

 Click Modify tab ► Clipboard panel ►    (Match Type Properties). 

 Select the North curtain wall, and then select the East curtain wall. 
 
5) Open the To Building 3D view. The new spacing is applied to both curtain walls. 

6) Save the project file. 
 
 

Attaching Walls to the Roof 
 

In this exercise, you attach interior and exterior walls to the roof. When you attach the curtain walls, 
Autodesk Revit warns you of consequences and modifies the placement of mullions. 

 
The completed exercise 
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15   Attaching walls to the roof 
 

1) Open the 03 Roof floor plan. 
 
2) Attach the basic walls: 

 
 While pressing CTRL, select all the interior walls and exterior walls, except the 

curtain walls. 
 

 Click Modify Walls tab ► Modify Wall panel ► click ATTACH TOP / BASE. 

 In the Options Bar, for Attach Wall, verify Top is selected. 

 In the drawing area, select the roof. 

 Press ESC to end the command. 
 

Section view shown for reference only 
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3) Attach the curtain walls: 
 
 Open the North elevation view. 

 Move the cursor over the curtain wall indicated by Mark 1, and press TAB until the 
status bar indicates that the curtain wall is selected, select the outside edge of the 
curtain wall, and then on the Modify Walls tab, at the Modify panel, click ATTACH 
TOP / BASE. 

 
 Select the roof indicated by Mark 2. 

 In the Error dialog box about curtain wall mullions, click DELETE ELEMENTS. 

 Open the East elevation view, and attach the East curtain wall to the roof. 
 
4) Open the To Building 3D view. 
 
5) On the View Control Bar, click Shadows Off ► SHADOWS ON. All walls extend up to the 

roof. Note the spacing of the top row of mullions/panels; because the spacing parameter 
cannot be satisfied, mullions are created where the walls and roof attach. 

 
6) Save the project file. 
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Modifying the Entry Deck 
 

In this exercise, modify the floor profile on the entry level to include a deck on the North side of the 
model. 

 
The completed exercise 
 

16   Modifying the entry deck 

 
1) Open the 02 Entry Level floor plan. 

 
2) Edit the profile of the floor: 

 
 Select the floor. Hover over the wall and use press TAB two times to select the floor. 

 Click EDIT BOUNDARY from Mode panel. 

 On the Draw Panel, click BOUNDARY LINE. On the North side of the model, click on 
the North wall in line with the right vertical sketch line, move the cursor up 11' [3300 
mm], and click to place the endpoint of the line. 

 

 
 Press ESC to finish this line. 

 On the Options Bar, select CHAIN. 

 At the intersection of the double door and the North wall draw a sketch line from the 
interior intersection up 6'' [200 mm] North and then West to the end of the Northern 
wall along the exterior side. 
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 Continue drawing a line from the left endpoint of the North wall and extending up  
3' 6'' [1000 mm]. 
 

 Connect the line with the upper endpoint of the 11' [3000 mm] vertical line drawn 
previously. 

 
 

 From Modify panel, click SPLIT, and split the North model line at 
both sides of the door opening. 
 

 
 

 On the Modify | Floors ribbon, click MODIFY. 

 Select the segment at the door opening, and press DELETE. 

 Click Edit Boundary tab ► Draw panel ► BOUNDARY LINE, and complete the 
profile to the right of the door, as shown. Press Esc to exit the command. 

 
 

 On the Mode panel, click FINISH EDIT MODE. 
 

 In the Alert dialog box, click NO. 
 

3) Add a wall to the entry deck: 
 
 Click Architecture tab ► Build panel ►  WALL. 

 In Properties palette ► Change Element Type drop-down and select Basic Wall : 
Retaining - 12'' Concrete [Basic Wall : Retaining 300mm Concrete]. 

 
 On the Options Bar, for Location Line, select CORE FACE: INTERIOR. 
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 Draw a wall from left to right on the slanted floor line, as shown and press ESC to exit 
the command. 

 
 

 Select the wall previously created. 

 In Properties palette, under Constraints, for Base Constraint, select  
00 FOUNDATION, and click APPLY. 
 

4) Modify the floor: 
 
 In the drawing area, select the floor. 

 Click EDIT BOUNDARY from Mode panel. 

 Select the short vertical line above the West wall, and drag it to the right, as shown. 

 
  

 On the Mode panel, click FINISH EDIT MODE. 

 In the Alert dialog, click NO. 
 

5) Open the To Building 3D view. 
 

6) Save the project file. 
 

Adding a Sloped Floor 
 

In this exercise, you add a sloped floor to the entry deck to create a ramp up to the entry door. 

 
 
The completed exercise 
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17   Adding a sloped floor 
 

1) Open the 02 Entry Level floor plan. 
 

2) Sketch the floor: 
 

 Click Architecture tab ► Build panel ► FLOOR. 

 On the Draw panel, click  LINE. 

 On the Options Bar, verify that Chain is selected. 

 Beginning at the left endpoint of the 6'' [200 mm] north wall and moving 
counterclockwise, sketch the floor to complete the deck previously drawn, as 
shown. 

 

 
 

 Click Create Floor Boundary tab ► Draw panel ►  SLOPE ARROW. 

 Select the midpoint of the West model line, and then select the East model line. 

 
 On the Create Floor Boundary tab, select MODIFY. 

 Select the slope arrow. 

 In Properties palette, under Constraints, for Height Offset at Tail, enter -1' [-300 mm], 
and click OK. 

 
 On the Floor panel, click FINISH EDIT MODE. 

 In the Alert dialog box, click NO. 
 

3) Open the North elevation view. The sloped floor begins at the lower level and extends to 
the entry level. 
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4) If the sloped floor does not meet the slope of the terrain, edit the floor sketch, and change 
the Height Offset at Tail property of the slope arrow. 

 
5) Save the project file. 

 

Adding Stairs and Railings 
 

In this exercise, you complete the interior of the model by adding a staircase on the lower level, and 
then adding and modifying railings on the lower level and the entry level. 
 

 
The completed exercise 
 
 

18   Adding stairs and railings 
 

1) Open the 01 Lower Level floor plan. 
 
2) Add stairs: 

 
 Zoom in to the East side of the model. 

 Click Architecture tab ►Circulation panel ►  STAIR. 

 Click near the double doors to start the stair run at Mark 1. 

 Move the cursor to the left until the tooltip indicates that no risers remain at Mark 2, 
and click to specify the stair endpoint. 
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 The stairs and railings are created automatically. 

 In the Mode panel ► click FINISH EDIT MODE. 

 
3) Edit the floor profile: 
 

 Open the 02 Entry Level floor plan. 

 Zoom in to the East side of the model. 

 Select the floor. 

 In the Mode panel ► click EDIT BOUNDARY. 

 On the Draw panel, click  LINE. 

 On the Options Bar, verify that Chain is selected. 

 Click at the corner of the model lines below the stairs to specify the start point. 

 Move the cursor to the left, enter 6' [1800 mm], and press ENTER. 

 Move the cursor up, enter 3' 4'' [1100 mm], and press ENTER. This distance is the 
width of the stair and its stringers. 

 
 Move the cursor to the right, and click on the vertical line to complete the sketch. 

 
 On the Modify | Floors ► Edit Boundary tab, click MODIFY. 

 
 Select the vertical model line closest to the stairs, and drag the bottom endpoint up to 

the endpoint of the short horizontal line drawn previously. 
 

 
 

 From the Modify | Floors ► Edit Boundary tab ►click FINISH EDIT MODE. 

 In the Alert dialog box, click NO. 
 

4) Move the stairs and railings: 
 
 Using a selection window, select the stairs and railings. To select only elements 

completely within the boundary of the window, drag the cursor from left to right. 

 From the Modify panel ► click   MOVE. 
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 Click the lower-left corner of the stairs as the move start point. 

 Click the lower corner of the modified floor profile as the move end point, and then 
press ESC. 

 
 

5) Modify the railing type: 
 
 Open the To Building 3D view. 

 While pressing CTRL, select both railings (zoom in as necessary). 

 In Properties palette ► Change Element Type drop-down and select  
Railing : Guardrail - Pipe [Railing : 900mm Pipe]. 
 

6) Add a railing to the entry deck: 
 
 Open the 02 Entry Level floor plan. 

 Click Architecture tab ► Circulation panel ► RAILING. 

 On the Draw panel, click  PICK LINES. 

 On the Options Bar, for Offset enter 4'' [150 mm]. 

 Zoom to the entry deck on the North side of the model. 

 Click the interior of the angled floor on the right, and then click the interior of the 
adjacent vertical floor line, as shown. 

 

 
 

 Click MODIFY, and then select the angled railing. 

 Drag the left endpoint to the right, so that the resulting railing extends just past the 
retaining wall. 

 
 Select the vertical railing, and drag the lower endpoint up until the resulting railing is 

10' [3000 mm]. 
 

 In Properties palette, for Type, select Railing: Guardrail - Pipe [900mm Pipe], and 
click OK. 
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 On the Modify | Create Railing Path tab ►click FINISH EDIT MODE. Press ESC to 
exit the command. 

 
 Add railing to the North side of the entry ramp as shown below. 

 
 

Entry deck railing    Entry ramp railing 

 
 

7) Add a railing on the North side of the interior stairs: 
 

 Click Architecture tab ► Circulation panel ►  RAILING. 

 On the Draw panel, click  PICK LINES. 

 On the Options Bar, for Offset enter 4'' [150 mm]. 

 Click to the left of the vertical floor line above the stairs, and then click above the left 
north edge of the stairs. 

 

 From the Modify panel ► click  TRIM. 

 Select the left side of the horizontal railing, and then select the vertical railing. 

 From the Mode panel ► click  FINISH EDIT MODE. 
 

 Add railing to the South side of the Stair 
 

North stair railing    South stair railing 
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8) Add a railing to the balcony: 
 
 Zoom to the lower-right corner of the model. 

 Click Architecture tab ► Circulation panel ► RAILING. 

 On the Draw panel, click   PICK LINES. 

 On the Options Bar, for Offset enter 4'' [150 mm]. 

 Click above the South floor line, and, continuing in a counterclockwise direction, click 
the interior of the remaining two floor lines that define the balcony. 

 

 
 

 On the Modify | Create Railing Path tab, click MODIFY. 

 Select the last line drawn, and drag the left endpoint to the right, just to the East of 
the exterior wall. 

 
 Select the South railing line, and drag the left endpoint to the right until it touches the 

exterior wall near the door. 
 

 

 From the Mode panel ► click  FINISH EDIT MODE. 
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9) Zoom in to the stairs, and use the same technique to add a railing below the stairs. If 
necessary, drag the right endpoint of the railing to the wall on the right. 

 

 
 

10) Fix Entry Level ramp railing 

 Open {3D} 3D Views if existing, otherwise from the Quick Access toolbar click  
DEFAULT 3D VIEW. 

 
 Orient the View Cube such that the North side of the house is facing you.  Currently, 

the railing is floating in the air as shown below. 
 

 
 Select the railing on-screen 

 

 From the Mode panel, click  EDIT PATH. 
 

 From the Tools panel, click    PICK NEW HOST. 
 

 Select the ramp element highlighted in blue. 
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 From the Mode panel ► click  FINISH EDIT MODE. 
 

 
 

11) Open the To Building 3D view. 
 
12) Save the project file. 

 
 

Modifying the Roof 
 

In this exercise, you modify the profile of the roof in order to extend the roof over the entry deck. 

 
The completed exercise 
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19   Modifying the Roof 
 

1) Open the 03 Roof floor plan. 

2) In the drawing area, select the roof. 

3) From the Mode panel ► click   EDIT FOOTPRINT. 

4) Modify the roof profile: 

 On the Tools toolbar, click  SPLIT, and split the top edge of the roof profile by 
clicking to the right of the entry deck. 

 

 
 
 On the Modify | Roofs tab ► Edit Footprint tab, click MODIFY. 

 Select the left segment of the split roof line, and press DELETE. 

 From the Draw panel ► click  LINE. Draw a line parallel to the edge of the entry 
deck. Press Esc to exit the command. 

 
 

 Select the Roof Boundary line that was just created. 

 On the Modify Roofs ► Edit Footprint tab, click  MOVE. Move the line 2' [610 
mm] to the North. 
 

 Select the right segment of the roof line, and drag the left endpoint to the intersection 
with the vertical floor line. 
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 On the Draw panel, click  LINE. 
 

 Draw a line from the end of the right segment up to the end of the left segment. 

 

 From the Mode panel ► click  FINISH EDIT MODE. 
 

5) Modify the Retaining Wall: 
 
 Select the 12" concrete retaining wall. 

 Click Modify Walls tab ► Modify Wall panel ► click ATTACH TOP / BASE. 

 In the Options Bar, for Attach Walls, select TOP. 

 Select the roof to attach the wall to the roof. Press ESC to exit the command. 

 
6) Open the To Building 3D view. Right-click in the drawing area and select View Properties. 

In the Instance Properties dialog box, under Graphics, click EDIT next to Graphic Display 
Options. In the Graphic Display Options, under the Background category, select Gradient 
Background. Select OK twice. 

 
7) Save the project file. 
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Documenting the Project 
 

In this exercise, you add tags to the project and schedule doors and rooms. You change an element 
in the door schedule and see that the change is automatically made in the associated plan. You also 
add color fill to rooms and modify crop regions for several views that you later add to a presentation 
sheet view. 
 

 
The completed exercise 
 
 

20   Documenting the project 
 

1) Create a section view. 

 Open the 02 Entry Level floor plan. 

 Click View tab ► Create panel ► SECTION. 

 Click on the left side of the model to begin the section and end it on the right side, 
making sure it cuts through the stairs. 

 
 Press ESC to exit the command. 

 Double-click the middle of the section head circle to display the section view. 
Alternatively, in the Project Browser under Views, expand Sections (Building 
Sections), and double-click Section 1. 
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2) Add door and window tags: 
 
 Open the 02 Entry Level floor plan. 

 Click Annotate tab ►  Tag panel ►  TAG ALL. 

 In the Tag All Not Tagged dialog box, press CTRL, and under Category, select 
WINDOW TAGS. 

 
 Click OK. 

 

 Open the 01 Lower Level floor plan, and use the same procedure to tag all doors and 
windows in the view 
. 

3) Create a door schedule: 

 Click View tab ►  Create panel ►  Schedules drop-down ►  
SCHEDULE/QUANTITIES. 
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 In the New Schedule dialog box, for Category, select DOORS, and click OK. 
 

 
 

 In the Schedule Properties dialog box, for Available fields, select FAMILY AND 
TYPE, and click ADD. 

 
 Add the following fields: Width, Height, and Mark. 

 
 Using the Move Up button, move Mark to the top of the list so that it displays first in 

the schedule. 
 

 Click the Sorting/Grouping tab, for Sort by, select Mark, and click OK. 
 

 Drag the right column boundary of the Family and Type column to expand it to its full 
width. 

 

 
 

4) Change a door schedule: 
 
 For the Mark 7 door, click the Family and Type field, and select  

Bifold-4 Panel : 60'' x 84'' [M_Bifold-4 Panel : 1525 x 2134mm]. 
 

 Open the 01 Lower Level floor plan. Notice that the bedroom door tagged 7 is now a 
bi-fold door. Changes made in the schedule are automatically synchronized in the 
associated plan. 

 
 In Properties palette, select Single-Flush: 30'' x 84'' [M_Single-Flush: 0762 x 

2134mm] to return the door to the original family and type. 
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 In the Project Browser, under Schedules/Quantities, double-click Door Schedule. The 
Mark 7 door is also restored to the original type in the schedule. This bi-directional 
associativity in Autodesk Revit ensures that changes made to any part of the design 
are coordinated in all associated views, including schedules. 

 
5) Modify the properties of the three retaining walls to specify them as bounding elements 

for room area calculation: 
 
 Open the 01 Lower Level floor plan. 

 
 On the Modify tab, click MODIFY. 

 
 While pressing CTRL, select the three retaining walls, and click 

 
 

 From the Properties palette, under Constraints, select Room Bounding, and click 
APPLY. 

 
 Press ESC to deselect retaining walls. 

 
6) Create a Room schedule: 

 
 Click View tab ► Create panel ► Schedules drop-down ► 

SCHEDULES/QUANTITIES. 
 

 In the New Schedule dialog box, for Category, select ROOMS, and click OK. 

 Add the following fields: Number, Name, Area, and click OK. The schedule is empty 
but is updated when you add rooms and room tags to the building. 

 
 

7) Add rooms and room tags on the entry level: 
 
 Open the 02 Entry Level floor plan. 

 Click Architecture tab ► Room & Area panel ►  ROOM. 
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 Click to the left of the stairs to tag the large room, click in the upper room on the West 

side of the building, and then click in the small room on the West side. 

 
 On the Place Room tab, click MODIFY. 

 
 Double-click the tag text in the large room, change it to Entry, and press ENTER. 

Change the tag text in room 2 to Bedroom, and the text in room 3 to Store. 
 

 
 

8) Add rooms and room tags on the lower level: 
 
 Open the 01 Lower Level floor plan. 

 Click Architecture tab ► Room & Area panel ► ROOM. 

 Beginning in the large room on the right and moving clockwise, click in each room to 
add the tags. 
 

 On the Place Room tab, click MODIFY. 
 

 Double-click the tag text in the large room, change it to Living Room, and then press 
ENTER. 

 
 Change the tag text in room 5 to Bedroom, the text in room 6 to Bathroom, and the 

text in rooms 7 and 8 to Store. 
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9) Open the Room Schedule view to see that it includes data for the specified fields. 
 

10) Define the floor in the Entry: 
 

 Open the 02 Entry Level floor plan. 

 Click Architecture tab ► Room and Area panel ► ROOM SEPARATOR LINE. 
 

 Trace the floor line from the North wall down to and around the stairs to define the 
Entry room and create a separate floor profile for that room. 

 
Before room separation line    

 

 
 
After room separation line 
 

 
 
The area for the entry room is updated in the room schedule. 
 

11) On the Design Bar, click MODIFY. 
 
 



A u t o d e s k ®  R e v i t ®  G e t t i n g  S t a r t e d  G u i d e  | 62 

12) Modify tags: 
 
 Open the 01 Lower Level floor plan. 

 Double-click the tag for one of the windows in the South wall, enter A, and press 
ENTER. 
 

 In the Alert dialog box about changing a type parameter, click YES. 

 Open the 02 Entry Level floor plan. 

 Double-click the tag for one of the windows in the west wall, enter B, and press 
ENTER. 
 

 In the Alert dialog box, click YES. 

 
13) Add color fill to the rooms: 

 In the Properties palette, Graphics section, click NONE value for Color Scheme. 
 

 Set Category to ROOMS and NAME field 

 
 
 Click OK. 

 

 Click Annotate tab ► Color Fill panel ► Color Fill Legend. 
 

 Left click just to the right of the model to locate the Room Legend. 
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 Select the left vertical wall, and move it slightly to the left. All of the walls resize to 
accommodate the new wall dimension. The color fill in the bedroom and storage 
room readjusts and the room areas are automatically updated. 
 

 Open the Room Schedule view to see that the bedroom and storage room areas 
have changed. 
 

 On the Standard toolbar, click  UNDO to restore the wall to its original dimension. 
 

 Reopen the 02 Entry Level floor plan and verify the wall has changed. 
 

14) Open the 01 Lower Level floor plan and repeat the previous procedure in that view. 

 
 

15) Modify a crop region to create a view for a sheet: 
 Open the 01 Lower Level floor plan. 

 On the View Control Bar, click SHOW CROP REGION. 

 Enter ZF to zoom to fit the entire view in the drawing window. 

 Select the crop region, and drag the triangular blue controls to shrink the region 
around the model. 
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 On the View Control Bar, click HIDE CROP REGION. 

 
16) Using the same method, modify the following views: 

 
 02 Entry Level floor plan 

 East elevation view 

 North elevation view 

17) Save the project file 

 

 

 

 

Creating a Solar Study 
 

In this exercise, you create an animation of the solar activity at a particular place and time in order to 
study the light and shadows that affect the building site. 
 

 
 
 
The completed exercise 
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21   Creating a solar study 
 

1) Open the To Building 3D view. 

2) On the View Control Bar, verify Shadows is turned ON. 

3) On the View Control Bar, click Sun Path icon 

 Click Sun Settings... 

4) In the Sun Settings dialog box, click SINGLE-DAY. 

5) On the Single-Day tab, select any one of the solar studies in the list, and click RENAME. 

6) In the Rename dialog box, for New, enter One Day Solar Study - Your Location - 
Summer Solstice (Winter Solstice if you are in the southern hemisphere), and click OK. 

 
7) In the Sun Settings dialog box: 

 Under Settings, for Place, click  , select Default City List, select a city near your 
location, and click OK. Refer to Mark 1. 
 

 

 Mark 2: For Date, enter 6/21/2014. 

 Mark 3: For Time Interval, select 15 minutes. 

 Mark 4: Clear Ground Plane at Level so that the shadows fall on the terrain. 

 

 Click OK. 

8) On the View Control Bar, click Sun Path icon ►  PREVIEW SOLAR STUDY. 

9) On the Options Bar, click PLAY. The solar study animation is displayed, showing the 
progression at 15-minute intervals for the location and date specified. 
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10) Export the animation: 

 Click  ►  Export ►  Images and Animations ►  SOLAR STUDY. 

 In the Length/Format dialog box, change Frames/sec to 1  

 In the Length/Format dialog box, change Visual Style to SHADED WITH EDGES  

 

 Click OK. 

 In the Export Animated Solar Study dialog box, click the DESKTOP icon, and click 
SAVE. 
 

 In the Video Compression dialog box, for Compressor, select FULL FRAMES. 
(Uncompressed), and click OK. The animation is played again as the AVI file is saved 
to your desktop. 

 
 On your desktop, double-clicking on the AVI file displays the animation. Move the 

scroll bar to change the time. 
 

11) Save the project file 
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Creating a Sheet 
 

In this exercise, you add multiple views to a sheet. You also change the roof slope parameter to test 
the parametric capabilities of Autodesk® Revit®. The walls that are attached to the roof are updated 
to maintain constraints with the modified roof. 
 

 
 
 
The completed exercise 
 

22   Creating a sheet 
 

1) Create a sheet: 

 In Project Browser, right-click Sheets (all), and click NEW SHEET. 

 In the Select a Title block dialog box, click OK. 
(E1 30 x 42 Horizontal should be the default) 

 In the Project Browser, expand Sheets (all), right-click A101 - Unnamed, and click 
RENAME. 

 
 In the Sheet Title dialog box, for Name, enter Presentation, and click OK. 

 
 

2) Turn off elevation markers in plan views: 
 In Project Browser, open 01 Lower Level floor plan 

 
 Window select one of the elevation markers, right-click in canvas window, select 

HIDE IN VIEW, and click CATEGORY 
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 Open 02 Entry Level floor plan view and repeat the above steps 

 
3) Drag the 01 Lower Level floor plan from the Project Browser onto the upper-left corner of 

the sheet, and click to place it as indicated by Mark 1 below. 
 

4) Add the following views to the sheet: 

 Mark 2: 02 Entry Level floor plan 

 Mark 3: North elevation 

 Mark 7: East elevation 

 Mark 4: Door Schedule 

 Mark 5: Room Schedule 

 Mark 6: Section 1 

 Mark 7: East elevation 
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Note: If a view is too large to fit on the sheet, place it in the drawing, right-click, and click 
Activate View. In the Properties dialog box, for View Scale, select a different scale. Click 
OK, right-click the view again, select Deactivate View, and reposition it on the sheet. 
 

5) Modify the roof slope: 

 In the drawing area, right-click the East elevation view, and click ACTIVATE 
VIEW. 
 

 Select the roof. 

 In Properties palette, under Dimensions, for Slope, enter 4''/12" [15°], and click 
APPLY. In all views, the walls and curtain walls that attach to the roof are 
extended and maintain the connection to the modified roof. 

 
 Change the slope parameter back to 1'' /12” [5°]. The walls and curtain walls are 

updated with the roof. 
 

 In the East elevation view, double-click the height value for the 03 Roof Level, 
and enter a value of 12’. In all views, the walls and curtain walls that attach to the 
roof maintain the connection to the modified roof. 

 
 Right-click, and click DEACTIVATE VIEW. 

Any modification to the model is updated in the project drawings so that they are always 
coordinated. Try deleting or moving interior walls and doors; the changes will be made in 
all drawing views and schedules. 
 
 

Create a gbXML Export 
 

In this exercise, you will export the model to the gbXML format for use in analytical programs such as 
Autodesk® Green Building Studio® software. 
 

 
 
The completed exercise 
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23   Creating a gbXML export 
 

1) Open Section 1 view. 

2) Change Visibility/Graphics: 

 Enter VG for the Visibility/Graphics Overrides for Section: Section 1 dialog box. 
 

 In the Visibility/Graphics dialog box, expand the Rooms category in the Visibility 
column, select INTERIOR FILL and click OK. Notice that the blue fill representing 
the Room volume does not extend beyond the 03 Roof level. 

 
3) Change the Room offset: 

 Open 02 Entry Level 

 Press and hold CTRL and select the Room Element in the Entry, Bedroom, and Store 
areas, by selecting the ―X‖ in each space indicated in red as shown in the image 
below: 

 
 

 In the Instance Properties dialog box, under Constraints section, set Limit Offset to 
14'. The entire Room must extend beyond the roof. 

 
 Open Section 1 view to verify Room extends beyond the roof. 

 
4) Delete Area Separation Line: 

 Open 02 Entry Level floor plan. 
 

 Press and hold CTRL to select (4) Area Separation Lines created in a previous 
exercise as indicated in red below. 

 
 Click DELETE key. 
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5) Manage Area and Volume Settings: 

 Click Architecture tab ► Room & Area panel drop-launcher arrow ► AREA AND 
VOLUME COMPUTATIONS. 
 

 In the Area and Volume Computations dialog box select AREAS AND VOLUMES 
and select AT WALL CENTER. 

 

 
 

 Click OK. 
 

 In the Section 1 view, confirm that the blue room boundaries are now touching the 
inside face of the roof element. 

 

 
 

6) Export to gbXML: 

 Open To Building 3D View. 

 Click ►   Export ►  gbXML 

 In the Export gbXML dialog box, change Building Type to SINGLE FAMILY. 

 Enter the PROJECT ADDRESS for your location. 
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 Use the View Cube in the viewing window to navigate around the model and identify 
that all interior spaces are represented with a blue volume. 
 

 Click NEXT… to create the gbXML file. By default, the XML file name takes on the 
same name as the RVT file in the same directory location.  

 
 Click SAVE to create the XML file. 

 
 SAVE the RVT file when done. 

 

This is the completion of this Getting Started tutorial. 
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APPENDIX 
 

Autodesk® Revit® - Mouse Interface and Keyboard Shortcuts 
 
 
Mouse Interface 
 
Select Element = Left Click 

Pop-Up Menu = Right Click 

Zoom In = Scroll-Wheel forward 

Zoom Out = Scroll-Wheel backward 

Pan = Hold Scroll-Wheel Down and Drag 

Rotate View in 3D = Shift Key + Scroll-Wheel Down + Drag 
 
View Control 

HL  Hidden Line 

SD  Shading with Edges 

VG  Visibility / Graphics 

VP  View Properties 

WF  Wire Frame 

ZA  Zoom All to Fit 

ZC  Previous Scroll Zoom 

ZX  Zoom to Fit 

ZV  Zoom Out (2x) 

ZZ  Zoom in Region 

F5  Refresh Window 

 

Snap Overrides 

SE  Endpoint 

SC  Center 

SH  Horizontal / Vertical 

SI  Intersection 

SM  Midpoint 

SN  Nearest 

SO  Snaps Off 

SP  Perpendicular 

SQ  Quadrants 

SR  Snap To Remote 

SS  Standard Snapping 

ST  Tangent 

SW  Work Plane Grid 

 

 

 

 

Edit 

AR  Array 

CO  Copy 

DE  Delete 

GP  Group 

LO  Lock Objects 

MD  Modify 

MM  Mirror 

MV  Move 

PR  Properties 

RO  Rotate 

 

 

Modeling 

WA  Wall 

WN  Window 

DR  Door 

CM  Component 

LI  Modeling Lines 

 

 

 

 

 

 

 

 

 

 

 

 

Drafting 

DI  Dimension 

DL  Detail Lines 

EL  Spot Elevation 

GR  Grid 

LL  Level 

RP  Reference Plane 

RT  Room Tag 

TX  Text 

TG  Tag 

 

 

 

Tools 

AL  Align 

LW  Linework 

OF  Offset 

PT  Paint 

SF  Split Face 

SL  Split Walls and Lines 

TR  Trim and Extend 


